lettura facile

La funzione SOMMA.PIÙ.SE() di Excel

In questa lezione ti parlo di una funzione che ti permette di fare una somma condizionata su Excel considerando due o più criteri di selezione. E' la funzione =SOMMA.PIÙ.SE()

=SOMMA.PIÙ.SE(int_somma; int_criterio1; criterio1;...)

Questa funzione è composta da tre parametri obbligatori

  • int_somma
    il primo parametro è l'intervallo dove si trovano i numeri da sommare
  • int_criterio1
    il secondo parametro è l'intervallo dove si trovano le informazioni da selezionare con il primo criterio
  • criterio1
    è il primo criterio di selezione

A questi tre parametri obbligatori puoi aggiungere altri parametri facoltativi per aggiungere altri intervalli e criteri di selezione.

=SOMMA.PIÙ.SE(int_somma; int_criterio1; criterio1; int_criterio2; criterio2;...)

Ti faccio un esempio pratico

Digita questa tabella sul foglio Excel.

un esempio di tabella

Poi digita questa funzione =SOMMA.PIÙ.SE(B2:B5;C2:C5;"RM") nella cella B7

digita =SOMMA.PIÙ.SE(B2:B5;C2:C5;"RM")

Questa funzione somma tutti i valori nella prima colonna (B2:B5) che hanno il valore "RM" nella seconda colonna (C2:C5)

Il risultato è una somma 4+2+3 uguale a 9

il risultato è 9

Ora aggiungi un secondo criterio di selezione

Digita la funzione =SOMMA.PIÙ.SE(B2:B5;C2:C5;"RM";D2:D5;"4 stelle") nella cella B7

digita  =SOMMA.PIÙ.SE(B2:B5;C2:C5;"RM";D2:D5;"4 stelle")

Questa funzione somma tutti i valori nella prima colonna (B2:B5) che hanno il valore "RM" nella seconda colonna (C2:C5) e il valore "4 stelle" nella terza colonna (D2:D5)

Il risultato è una somma 2+3 uguale a 5

la somma è uguale a 5

Nota. Il primo valore (4) sulla prima riga viene escluso dalla somma perché, pur avendo "RM" nella seconda colonna, non ha "4 stelle" nella terza colonna.

Puoi anche aggiungere ulteriori criteri di selezione.

Ad esempio, digita =SOMMA.PIÙ.SE(B2:B5;C2:C5;"RM";D2:D5;"4 stelle"; B2:B5; ">2")

digita =SOMMA.PIÙ.SE(B2:B5;C2:C5;"RM";D2:D5;"4 stelle"; B2:B5; ">2")

In questo caso la funzione somma tutti i valori nella prima colonna (B2:B5) che hanno il valore "RM" nella seconda colonna (C2:C5), il valore "4 stelle" nella terza colonna (D2:D5) e un valore maggiore di 2 nella prima colonna (B2:B5)

Soltanto il valore 3 sulla quarta riga soddisfa tutti i criteri di selezione.

Il risultato è 3.

il risultato è 3

In questo modo puoi sommare le informazioni in una tabella del foglio Excel considerando due o più criteri di selezione.

Nota. Se hai un solo criterio di selezione puoi anche usare la funzione SOMMA.SE() di Excel.

 




Non hai risolto il tuo problema? Scrivi una domanda




FacebookTwitterLinkedinLinkedin